WTV Watcher creating converted file with working directory in the converted name

Jan 11, 2011 at 10:15 PM

Hi,

I am using your program and using a different working directory and when the conversion is done and copied back to my Recorded TV directory it has the working directory name prepended to the file name. For example if the file is "Housexxxx.wtv" and I have the working directory set to "D:\Recorded TV\TempRec", the resultant file is named "TempRecHousexxxx.dvrms". Is there a way to stop this behavior?

Thanks,

Tim

Jan 20, 2011 at 9:41 AM

Have the same exact issue if I use a Working Directory setting different from the Recorded TV directory.  A prefix is added to the file with the working directory name.  In addition it appears that the new version "holds" the file as active so that the FileWatcher from the DVRMS Toolbox does not recognize that the file is available for processing.  I can move the file out of the directory.  Close WTV Watcher then and only then will File Watcher pick up the file.  Until this is fixed I was hoping to revert back to the .35 version but when I use the installer for this version it "phones home" and still installs version .46.  The only work around I have found is to change the wtvconverter command line to "wtvconverter c:\recorded tv\*.wtv" with no output directory.  This seems to allow File Watcher to see the file but has the side effect of appending the "- DVRMS" to the end of the file.  ANy chance of getting an installable version of .35?  Please advise.

Jan 25, 2011 at 8:23 PM

Hello.  Does anyone check these posts?  I also sent an email through codeplex with NO reply.  Looking for a little help here.  Thanks.

Jan 26, 2011 at 12:10 AM
Yes, I receive posts, but like many other people, I have a fulltime job that keeps me very busy.

If you've never posted to an open online forum before, you should know that receiving a response often takes quite a while, usually for just the above reason.

I can't promise anything, but i'll try to do some updates this coming weekend.

Cheers,

Paul

Sent via mobile device...as such, allow time for response when applicable.

On Jan 25, 2011, at 3:23 PM, MRL_CPlex <notifications@codeplex.com> wrote:

From: MRL_CPlex

Hello. Does anyone check these posts? I also sent an email through codeplex with NO reply. Looking for a little help here. Thanks.

Jan 26, 2011 at 1:29 AM

Thanks for the reply Paul.  That's all I was looking for.  Wanted to make sure the issue was noticed. FWIW I found a bit of a work around but it has it's own issue.  Basically set the Working Directory to be the same as the Recorded TV Directory.  Changed the Action to "C:Windows\ehome\wtvconverter.exe H:\Recorded TV".  This creates an error about the missing (1) destination placeholder but apparently it can be ignored.  As you know this tells the converter to leave the converted file in the same directory with the same name.  However a "- DVRMS" is appended to the end of the file.  The primary reason I was looking to use the Working Directory option in the first place was because the new version of WTV Watcher, .46, does not release the file when the conversion is complete.  DVRMS Toolbox can not process the file once this happens.  The only way I have been able to get it to work was as I mentioned above.  Previously was using the .35 version and never had an issue.  Is there any way for me to get and install the previous version until you are able to sort out the issues with the current version?  Thanks for the great work on this app.  Clearly has an audience and I consider it an important part of my Media Center setup.  Appreciate any consideration and if you need someone to test I can do that.

Jan 30, 2011 at 2:32 PM

yeah. at this point i'd suggest uninstalling and wiping your wtvwatcher settings before reinstalling. to clear your previous settings to default, find and delete the %APPDATA%\WtvWatcher.settings file before reinstalling.

no one else is reporting the "doesn't release the file" issue, but i wouldn't rule out that this is or is not happening without hard proof. because DVRMSToolbox is highly configurable, alot of people (myself included) misconfigure it, or configure it initially in such a way that it's very brittle to changes in the video processing pipeline. try sysinternals utilities to confirm for certain what is holding on to the file. http://support.microsoft.com/kb/232830

the source code is available for you to mess around with in more depth. if you figure it out, feel free to let me know, and i'll include it in the main source code.

Jun 21, 2011 at 12:58 PM

Hi,

I believe you need to add the backslash in the working directory part of the wtcwatcher.settings file under %appdata%.

This is what I have done and it fixes the file name issue you mentioned in your orginial post - I also was getting that issue,

Regards

Jun 21, 2011 at 1:04 PM

Sorry, 

I intended the final DVR-ms file to be located in the working directory at completion, but it is transfered back to the source directory.

Jun 21, 2011 at 2:52 PM

Since no reply was forthcoming, I gave up on this tool and configured DRVMSToolbox to do the job.

Jun 21, 2011 at 2:59 PM

Can you share the conversion script from the .wtv file to .dvrms file?  I would like to move down that path as well.  Thanks.

Sep 30, 2012 at 1:08 AM

This seems to be an old thread, but I just installed the program and have changed the working folder to another drive to make read/writes to different drives.  I then found the same issue of the directory selected was being treated as a file prefix.  The code is evidently not adding a '\' to the directory name and therefore the directory becomes a prefix to the filename.

This could be resolved two ways.

1) Fix the code to include the backslash

2) Allow users to modify in a text box the full path, rather than it having to be pulled directly from the directory chooser dialog.

Anyway, I found a fix based on pbruce's reply above about deleting the %APPDATA%\WtvWatcher.settings file

Just edit that file in notepad (yes type: %APPDATA% as the path to pull up the file) and in the line that contains your working folder directory, just add the slash to the end of the path.  Works fine now.